Firefox deaktiviert seit heute morgen viele Add-ons.

Hier werden aktuelle Meldungen diskutiert
[this is the place to discus news topics]
Antworten
Benutzeravatar
Mausolos
Insider
Insider
Beiträge: 1019
Registriert: 09 Mär 2015, 20:50
Wohnort: Vierländerregion

Firefox deaktiviert seit heute morgen viele Add-ons.

Beitrag von Mausolos » 04 Mai 2019, 11:24

Aufgrund eines abgelaufenen Zertifikats deaktiviert Mozilla Firefox weltweit eine Vielzahl von Add-ons.
Das lässt sich notdürftig so umgegen:
In der Adresszeile eingeben und die Warnung bestätigen.

Code: Alles auswählen

about:config
Nach [signatures] suchen lassen und dann im Feld

Code: Alles auswählen

xpinstall.signatures.required
per Doppelklick den Wert von true auf false umstellen.

Anschließend muss Firefox noch neu gestartet werden.
Jetzt sind die Add-ons im Untermenü Erweiterungen trotz Warnung wieder aktiv.

Angeblich arbeitet das Team bereits an der Fehlerbehebung. Wenn das geschehen ist, sollte der Wert für "xpinstall.signatures.required" wieder auf "true" zurückgestellt werden.
Linux :)

pferdchen

Re: Firefox deaktiviert seit heute morgen viele Add-ons.

Beitrag von pferdchen » 04 Mai 2019, 22:54

Super, endlich eine Lösung die auch funktioniert.
Ein Add-on bekomme ich aber trotzdem nicht zum laufen

Benutzeravatar
doelf
Moderator
Moderator
Beiträge: 34653
Registriert: 12 Feb 2004, 23:29
Wohnort: Alsdorf
Kontaktdaten:

Zertifikat abgelaufen: Firefox und Tor-Browser blockieren Add-ons

Beitrag von doelf » 04 Mai 2019, 23:41

Seit der Version 43 blockiert der Firefox aus Sicherheitsgründen unsignierte Erweiterungen, doch seit Samstagmorgen mitteleuropäischer Zeit können die Benutzer fast kein Add-on mehr aktivieren oder installieren. Schuld ist ein abgelaufenes Zertifikat, das zum Signieren der Add-ons genutzt wurde. Auch der auf Firefox basierende Tor-Browser ist betroffen. Es gibt einen Hotfix und einen Workaround.

Wie man den Hotfix bekommt
Mozilla ist diese Panne sichtlich peinlich, so dass man zeitnah einen Hotfix für die Kanäle Release, Beta und Nightly bereitgestellt hat. Dieser wird über "Firefox Studien" ausgeliefert, weshalb man in den Einstellungen unter "Datenschutz & Sicherheit" die Option "Firefox das Installieren und Durchführen von Studien erlauben" freigeben muss. Doch auch nach der Freigabe kann es bis zu sechs Stunden dauern, bis der Fix tatsächlich ankommt. Wenn man in der Adresszeile "about:studies" eingibt und "hotfix-update-xpi-signing-intermediate-bug-1548973" angezeigt wird, ist der Hotfix installiert und man kann die Erlaubnis für Studien wieder zurückziehen. Für den Firefox ESR (Extended Support Release) und Firefox für Android gibt es zur Stunde noch keine Lösung.

Der Workaround
Unser Forennutzer Mausolos hat einen temporären Workaround ausgegraben: Man kann die Signaturprüfung abschalten. Dazu gibt man in der Adresszeile "about:config" ein, nimmt den Warnhinweis zur Kenntnis und sucht nach dem Schlüssel "xpinstall.signatures.required". Per Doppelklick ändert man diesen Wert von "True" auf "False", startet den Firefox neu und schon laufen alle Erweiterungen - egal ob signiert oder nicht. Dies ist natürlich kein sinnvoller Dauerzustand, hilft aber über die kommenden Stunden hinweg.

Quelle:
https://blog.mozilla.org/addons/2019/05 ... n-firefox/
. Tails . Linux . USB . CD . Secure Desktop . IRC . Truecrypt . Tor .

Benutzeravatar
Mausolos
Insider
Insider
Beiträge: 1019
Registriert: 09 Mär 2015, 20:50
Wohnort: Vierländerregion

Re: Zertifikat abgelaufen: Firefox und Tor-Browser blockieren Add-ons

Beitrag von Mausolos » 05 Mai 2019, 21:15

Mozilla hat bereits die Versionen Firefox 66.0.4 für PC-Desktop und Android, sowie Firefox ESR 60.6.2 veröffentlicht. Es gibt aber wohl noch ein paar Problemchen. Schauen wir mal, ob sie's im Verlauf des Montags schaffen.

https://blog.mozilla.org/addons/2019/05 ... n-firefox/

Edit: Diesmal hat sich auch SuSE beeilt, Firefox ESR 60.6.2 über das Repo-Update bereitzustellen. :)

Code: Alles auswählen

MozillaFirefox-60.6.1_60.6.2-135.1_138.1.x86_64.drpm	06-May-2019 11:15 	195K
"xpinstall.signatures.required" konnte ich jetzt wieder auf "true" zurücksetzen.
Linux :)

Antworten